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1. Introduction 
Scleractinian corals form the foundation of coral reefs by constructing the framework on 
which reef-associated organisms rely for habitat and food. As a result, changes in coral 
growth, fission, fusion, recruitment, and mortality (i.e., coral vital rates) have direct 
consequences on the structure and function of coral reef ecosystems (Done 1992; 
Edmunds and Riegl 2020). Incorporating coral vital rates into robust models used to 
assess the impacts of environmental drivers on reef dynamics can help inform which 
management actions are most likely to improve reef resilience.  

NOAA’s Ecosystem Sciences Division (ESD), formerly the Coral Reef Ecosystem 
Division, has been monitoring Pacific coral populations and benthic communities since 
the early 2000s in a coherent effort now known as the Pacific National Coral Reef 
Monitoring Program (NCRMP). ESD monitors the status and trends of coral reefs 
across 40 primary islands, atolls, and shallow banks in the U.S. Pacific. To date, ESD 
has used snapshot visual assessments of coral communities and benthic photoquadrat 
imagery at randomly selected sites to generate coral demographic metrics (i.e., colony 
density, size structure, partial mortality). However, these methods do not track the same 
corals over time, limiting our ability to measure how coral colony-specific growth and 
mortality are impacted by factors such as colony characteristics (e.g., size, life history 
strategy) and external disturbances (e.g., temperature stress) (Brito-Millán 2019; Furby 
et al. 2017, Morais et al. 2021).   

Photogrammetry, a method of producing geometrically accurate large area imagery, has 
increased in popularity as a tool for studying spatio-temporal trends on coral reefs. 
Large area image analysis reduces costs and complexity of field operations, provides a 
permanent record of benthic communities, and can be used to track hundreds to 
thousands of coral colonies across multiple sites and time points, thus providing the 
ecological and spatial replication necessary to test the links between vital rates and 
environmental conditions (Rodriguez et al. 2022). However, manually annotating 
imagery and tracking coral colonies across time is labor intensive, taking approximately 
40 hours to annotate and link corals within ~10m2 of reef across two time points. 
Currently, fully manual annotation cannot keep up with the speed at which imagery is 
collected. To address this limitation, machine learning technologies have increased in 
popularity as a tool to reduce image annotation time while maintaining accuracy.  

One such example is TagLab, an open-source AI-assisted software created by the 
Visual Computing Lab (http://vcg.isti.cnr.it/) that uses a manually assisted workflow to 
semi-automatically annotate and track coral colonies across multiple time points (Pavoni 
et al. 2021). This document provides the standard operating procedures (SOP) for the 

http://vcg.isti.cnr.it/
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integration of TagLab into our current vital rates workflow as outlined in Rodriguez et al. 
(2022). The workflow includes 1) preparing sampling quadrats (optional) and a 
geodatabase in ArcGIS Pro, 2) semi-automatically annotating coral colonies within the 
specified sampling region of each orthomosaic in TagLab, 3) semi-automatically linking 
live coral colonies across time points in TagLab, and 4) merging TagLab coral colony 
species ID and linking to ArcGIS Pro geodatabase information to estimate vital rates. 
This SOP also provides a time savings comparison between manual annotation using 
the previous Vital Rates workflow (Rodriguez et al. 2021) and our TagLab-assisted Vital 
Rates workflow. We posit that, although TagLab remains an ongoing project of the 
Visual Computing lab and requires additional testing, it reduces personnel hours by 
40%, making it a worthwhile approach to quantifying coral vital rates.  
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2. Prepare Files in ArcGIS 
In this section, ArcGIS Pro 2.8.0 or later is used to create random sampling quadrats 
and a geodatabase for recording metadata and organizing shapefiles, fixing 
orthomosaic alignment issues if they arise, and exporting GeoTIFFs and shapefiles for 
use in TagLab. Each site will have its own geodatabase and set of quadrats that are 
used for every time point available. Given the time-consuming nature of manual and 
semi-automated coral annotation, a randomized sub-sampling strategy is used to 
provide enough coral colony transitions across a wide range of size classes to fit robust 
demographic models and still proceed efficiently through many sites’ worth of data. In 
our case, square quadrats (0.5 m2 area each, 15-25 per site) are randomly “placed” 
throughout the region of overlap between orthomosaics of the same site and corals with 
centroids that fall within the quadrats are annotated. This tutorial assumes a basic 
understanding of ArcGIS. Ensure that you have an ArcGIS Pro Advanced license to use 
all necessary tools and functions. 

2.1 Create an ArcGIS Project: 
1. Open a new ArcGIS project and use the ‘Add Folder’ tool under the ‘Insert’ tab to 

add the folder containing the orthomosaics and other TagLab-related files (e.g., 
M:\FixedSiteProducts\HAW_OCC_010\TagLab).  

2. Upload all available orthomosaics for a given site using the ‘Add Data’ tool under 
the ‘Map’ tab. 

3. Set the coordinate system for each orthomosaic. Under ‘Analysis,’ click on ‘Tools’ 
and search for Define Projection (Data Management Tools). 

a. Input Dataset or Feature Class = year_site-name_orthomosaic.tif 
b. Under ‘Coordinate Systems,’ set ‘Current XY’ to ‘WGS 1984 UTM Zone 

4N’ (‘Projected Coordinate System’ > UTM > WGS > Northern 
Hemisphere). 

c. If not previously done, right click to ‘Add to Favorites.’  
d. Zone changes depending on site location. 

4. The orthomosaic should already be properly scaled if it was scaled and oriented 
in Agisoft; however, confirm it is correctly scaled by using the Measure tool under 
the ‘Map’ tab and measuring an object of known distance (e.g., a scale bar). 

5. In most cases, the model colors will be incorrect. In the Raster Layer tab, click on 
the drop down menu under ‘Stretch Type’ and change to None.  

a. If the orthomosaic was not previously color corrected, right click on the 
orthomosaic in the Contents pane, select symbology, and change the 
RGB values.  

6. All orthomosaics should appear within the same region of the Map window. If this 
is not the case or the alignment is otherwise incorrect, refer to the following 
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section. 

2.2 Align and Export Orthomosaics: 
On rare occasions, orthomosaics do not align atop one another when imported into 
ArcGIS. When this error occurs, orthomosaics must be aligned in ArcGIS and exported 
for use in TagLab. If imported orthomosaics are already aligned in ArcGIS, skip this 
section. 

1. Select one orthomosaic to act as the reference orthomosaic (typically the 
orthomosaic with the most recent time point and/or most accurate metadata). All 
the other time points will be aligned to this orthomosaic. Right click on the 
reference orthomosaic in the Contents panel and select Zoom to Layer. 

2. In the Contents panel, select the orthomosaic that is getting aligned to the 
reference orthomosaic and select the ‘Fit to Display’ within the Georeference tab. 
This will move the orthomosaic to the same display extent as the reference 
orthomosaic.  

a. To access the Fit to Display tool, open the Imagery tab and click on 
Georeference to open up the Georeference tab.  

b. You may need to change the zoom settings on the reference model to 
improve the alignment between the orthomosaics. 

c. If the ‘Fit to Display’ tool is disabled, the orthoprojection and reference 
orthomosaic may be using different coordinate systems or one may not 
have a defined coordinate system. To fix this, from the Analysis tab, open 
the ‘Tools’ section and search for Define Projection (Data Management 
Tools). 

i. Input Dataset or Feature Class: new [georeferenced] orthomosaic 
ii. Coordinate System: WGS 1984 UTM Zone 4N 
iii. If the coordinate systems match but the Fit to Display tool is still 

disabled, click Set SRS.  
3. To fine tune alignment between the two models, click on Add Control Points 

within the Georeference tab. Select a point on the orthoprojection and the 
identical point on the reference orthomosaic. When both points are chosen, you 
may notice an orthomosaic jump to its new location.  

a. Choose a point that is unlikely to change between years, such as bolted 
down science equipment or shrimp/crab burrows in coral.  

b. Choose 3-5 control points to improve model alignment. 
c. If needed, use the rotate, move, and scale tools to fine tune alignment. 

4. Once the two orthomosaics are aligned, click Save in the Georeference tab and 
close the Georeference tab to remove the control points from the Map window.  
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5. Ensure that orthomosaic colors are corrected (i.e., remove Stretch Type) once 
alignment is completed.  

6. Orthomosaics need to be exported from ArcGIS in order to align with the 
quadrats in TagLab. Prior to exporting, ensure that shapefiles and orthomosaics 
have the same spatial reference coordinates. In some cases, the orthomosaic 
will need linear units converted from degrees to meters. 

a. In the Geoprocessing tab, search and select Project Raster (Data 
Management Tools). 

i. Input raster: orthomosaic 
ii. Output raster: Save to the site’s ARC folder (but not inside the 

default geodatabase) and add .tiff to the end of the site name.  
iii. Output coordinate system: Select one of the orthomosaics from the 

same site with an accurate geometric and projected coordinate 
system.  

iv. Select Run. 
v. Once the new tiff appears in the contents pane, fix the symbology 

by navigating to the Appearance tab and changing Stretch Type to 
None. 

7. Export updated orthomosaics by opening the Share tab and selecting Export 
Map. 

a. File Type: TIFF 
b. Name: Year_Site-Name_mos (save to the site ARC folder) 
c. Image compression: LZW. 
d. Pixels: Conserve the existing width:height ratio and choose a width similar 

to the orthomosaic exported from Agisoft to maintain a high resolution. 
Make pixel dimensions identical among all exported orthomosaics. 

e. Check “Write GeoTIFF tags.” 
f. Color depth: 32-bit with Alpha 
g. Do NOT alter the Map window view in between orthomosaic exports. 

2.3 Create Random Sampling Quadrats:  
1. To create the quadrats, start by generating random points in the orthomosaic 

region with multi-time point overlap. In the geoprocessing pane, select the Create 
Random Points (Data Management Tools) tool (Figure 1).  

a. Output Location: Site geodatabase 
b. Output Point Feature Class: RandomPoints 
c. Constraining Feature class: auto fill 
d. Choose the polygon tool to trace the region of overlap between 

orthomosaics. 
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e. Number of points: 25 (Long) 
f. Minimum allowed distance: 1 meter (Linear Unit) 

 

Figure 1. Create Random Points (Data Management Tools) tool allows the user to create a region 
in which random points are constrained (left). This tool is also used to set the number of random 
points and their minimum distance from one another (right). 

2. In the geoprocessing pane, select the Buffer (Analysis Tools) tool to create a 
circular buffer around the random points (Figure 2).  

a. Input Features: RandomPoints 
b. Output Feature Class: autofill 
c. Distance: 0.3535 Meters (Linear Unit) 
d. Method: Planar 
e. Dissolve Type: No Dissolve 
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Figure 2. The Buffer (Analysis Tools) tool allows the user to create a buffer (blue) of a specific 
diameter around the previously created random points (red). 

3. Turn the circular buffer into a square using the Minimum Bounding Geometry 
(Data Management) tool (Figure 3). Although this step is not required, it is done at 
the request of members of the computer science community that prefer working 
with polygons similar to pixels and square grids commonly used in automated 
and semi-automated image analysis. 

a. Input Features: RandomPoints_Buffer 
b. Output Feature Class: rename as Quadrats 
c. Geometry Type: Rectangle by area 
d. Group Option: None 
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Figure 3. The Minimum Bounding Geometry (Data Management) tool allows the user to turn the 
circular sampling region into a square. Once quadrats have been made, the user can change the 
symbology to no fill and a thick (3 point width) brightly colored perimeter to assist with annotating 
corals. 

4. Convert the quadrat geodatabase feature class into a shapefile feature class 
using the Feature Class to Shapefile (Conversions Tools) tool. 

a. Input Features: Quadrats 
b. Output Folder: Save to the ARC folder and keep the same file name. 
c. Change the symbology to no fill color and a red (or a similarly bright, 

contrasting color) perimeter with 3 point width. The quadrat color will not 
carry over to TagLab, but while using ArcGIS, the color is helpful for 
keeping track of the quadrats’ location. 

2.4 Set up the Geodatabase: 
Prior to starting annotations, a geodatabase in ArcGIS will be set up for easier metadata 
recording and file organization. The template shapefile within the geodatabase will be 
imported into TagLab to maintain backwards compatibility between the two platforms. 
After coral annotations and linking are completed in TagLab, shapefiles will be imported 
back into ArcGIS where the metadata will be added. 

1. Refer to Measuring coral vital rates using structure-from-motion photogrammetry 
at fixed sites: standard operating procedures and error estimates Appendix III - 
Setting up the Geodatabase. 
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(https://repository.library.noaa.gov/view/noaa/32739) to create the geodatabase 
and attribute tables required for collecting vital rates data. 

2. Once the geodatabase and template feature class (labeled as “template” in the 
geodatabase) have been created, convert the feature class into a shapefile using 
the Feature Class to Shapefile (Conversions Tools) tool.  

a. Input Features: Year_Site-Name_Initials 
b. Output Folder: Save to the site’s Arc folder (outside of the geodatabase).  

3. Before saving, make sure the shapefile has the same spatial reference 
coordinates as the site orthomosaics. Both files should have a projected 
coordinate system of WGS 1984 UTM Zone 4N (zone will change depending on 
site location). To change the coordinate system of a shapefile, use the Project 
(Data Management Tools) tool within the Geoprocessing Toolbox.  

a. Input Dataset: Shapefile with incorrect coordinate system 
b. Output Dataset: Keep the same name as previous 
c. Output Coordinate System: WGS_1984_UTM (add in zone specific to the 

site location.) 
4. Save all changes to the Arc Project.  

3. Setting up TagLab 
This section outlines the process of exporting coral annotations using TagLab version 
2023.1.23. TagLab is regularly updated; therefore, some steps may not align with more 
recent versions of the software. 

3.1 Preliminary Steps: 
1. Please refer to https://github.com/cnr-isti-vclab/TagLab for information regarding 

TagLab dependencies install and updates regarding software compatibility. 
Dependencies required prior to opening TagLab include: 

a. Python form 3.8 or greater (Python 3.7 will stop receiving security updates 
in June 2023). 

b. CUDA 11.6 or 11.7 
2. When installing Python, a pop up window will appear, prompting the user to 

complete the download process. In the pop up window, 
a. check Add to PATH at bottom, 
b. select custom installation, 
c. keep all optional features, 
d. advanced options > customize installation location, and 
e. install in the following location: c:\Program Files\Python. 

https://repository.library.noaa.gov/view/noaa/32739
https://github.com/cnr-isti-vclab/TagLab


10 

 

3. Download TagLab from https://github.com/cnr-isti-vclab/TagLab  
a. Click on the green “Code” tab at the top right corner of the GitHub page 

and download as a zip file.  
b. Unzip the file and save it to the computer’s C drive. The file path should be 

C:\TagLab-main. 

3.2 Open TagLab: 
1. Open a command prompt window and change the directory to the TagLab folder 

file path: cd C:\TagLab-main.  
2. To start the program, type python TagLab.py into the next command line. 

TagLab may take several seconds to open (Figure 4). 

 

Figure 4. Command prompt window containing code required to open TagLab. If the command 
prompt directory is already within the C drive, the abbreviated code cd \TagLab-main can be 
used to access the TagLab folder. 

3. If TagLab does not open, check the command prompt window for error 
messages. There are several common error messages. 

a. Make sure you are using the correct Python and CUDA software versions.  
i. To check if you have the correct software version, type python --

version or nvcc --version to view the current version in 
use. 

b. If TagLab requires an update prior to opening (after running python 
TagLab.py, a message will appear saying to update TagLab before 
opening), use the code python update.py. 

https://github.com/cnr-isti-vclab/TagLab
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4. Using TagLab 

4.1 Navigate TagLab:  
The TagLab Interface: 

Following Figure 5, annotation and linking tools are located in the toolbar on the far left. 
The Labels window (top right) contains the labels dictionary with all required species 
codes and associated RGB fill values used to assign species codes. The Layers 
window (right, second from top) displays all loaded orthomosaics and their associated 
annotation layers. The Data Table window (right, third from top) contains all data 
regarding the annotations, and shapefile information will be stored there. Region Info 
window (right, second from bottom) provides detailed information regarding individual 
patch annotations. The Properties tab contains TagLab-derived data that is auto-filled, 
and the Attributes tab contains ArcGIS-derived information from the imported attribute 
table that can be manually edited. The Map Preview window (bottom right) maintains full 
view of the map when zoomed in, and the gray box displays the region currently in view 
in the center screen. The center screen view can be changed by moving the gray box in 
the Map Preview window.  

● To pan around the map regardless of the tool currently in use, press ctrl + left 
mouse button or, in the Map Preview (bottom-right of the workspace), drag the 
gray box to your desired location (Figure 5). 

● Regardless of the tool selected, zoom is always accessible by scrolling. 
● Press ctrl + z to undo a command. 
● The term “genet” is used in TagLab to describe the group of individual coral 

patches that make up a single coral colony (genet = colony).  
● All individual patches and quadrats within a given shapefile will be labeled with a 

unique ID number. To check the ID, patch size, etc., double click on the 
delineation and its associated information will appear in the Region Info box. IDs, 
species codes, etc. for all annotations within a shapefile can be found in the Data 
table, where unique ID is labeled as Id, and species code is labeled as Class 
(Figure 5).  

● In TagLab, a Map is the combination of orthomosaic and digital elevation model 
(if uploaded) along with their associated metadata that includes date, pixel size, 
and name.  

● For a list of shortcuts, click Ctrl + H (or navigate to Help > Help), but keep in mind 
that some of these shortcuts and tools may be outdated (Figure 6).  

● For additional information regarding the TagLab interface, go to file:///C:/TagLab-
main/docs/TagLab.html 
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Figure 5. The TagLab interface. 

 

Figure 6. Panel display of TagLab shortcut keystrokes. This window can be reached by selecting 
Help > Help. 

4.2 Create a TagLab Project: 
1. To create a new TagLab project, select File > New Project. 
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2. Import the orthomosaics into TagLab (Figure 7). 
a. Project > Add New Map 

i. Map Name: same as orthomosaic 
ii. RGB Image: the file path of the orthomosaic (click the 3 dots on the 

right side to browse for the orthomosaic). 
iii. Depth Image: the file path of the DEM (optional). 
iv. Acquisition Date: the date that the raw images were collected.  
v. Pixel size (mm): leave blank.  

b. Currently, TagLab does not support map sizes larger than 32767 × 32767 
pixels. 

c. Map settings and file paths can be changed later by going to Project > 
Maps Editor. 

 

Figure 7. Select Project > Add New Map and the Map Settings window will appear. 

1. The quadrat shapefile must be separately added to orthomosaics within the 
project in order to appear atop each orthomosaic. Import the site-specific quadrat 
shapefile by selecting File > Import > Import Shapefile. In the Shapefile Attribute 
Editor window: 

a. Shapefile type: Labeling layer  
b. Do not import any fields 
c. Select class name: None 

2. (Optional) Import the ArcGIS-produced shapefile used for coral annotations into 
TagLab. Select File > Import > Import Shapefile and choose the shapefile labeled 
TYear_Site-Name_Initials within the site Arc folder. The Shapefile Attribute Editor 
will appear automatically (Figure 8). 

a. Shapefile type: Labeling layer 
b. Fields to import: all attribute table columns 
c. Select class name: Spec_Code 

d. If annotations already exist within the shapefile, ensure that species code 
names and associated RGB values match the label dictionary loaded into 
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TagLab. If these values do not match, TagLab will crash when trying to 
upload the shapefile. 

e. Select Ok 

 

Figure 8. The shapefile attribute editor allows the user to choose which fields in the Arc attribute 
table are imported into TagLab. Fields imported into TagLab will be visible in the Data Table 
window. 

3. If the label dictionary in TagLab is missing several species codes or contains 
incorrect RGB values, edit the labels dictionary by going to Project > Label 
dictionary editor.  

a. Do NOT alter the dictionary if it is already in use for other projects or 
annotators! If it is necessary to alter a label dictionary, notify the project 
lead before doing so. 

b. Double click on the incorrect label and change the RGB values and/or 
species code name. When complete, click Update. New labels can be 
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added as well using the label editor. 
c. When all species codes are in the label dictionary, click Save and save to 

M:\FixedSiteProducts. 
4. Once maps and shapefiles have been imported into TagLab, go to File > Save as 

and save the TagLab project in the site-specific Products folder.  
a. Do NOT close down TagLab without saving changes to your project.  
b. Enable automatic save by going to File>Preference.  

4.3 Annotate Coral Patches: 
Previously, annotations were completed manually in ArcGIS. However, annotations can 
now be completed in TagLab using both manual and semi-automatic annotation. Below 
are some tips and explanations on how to use TagLab’s annotation tools. Most tools 
can be found on the left side of the TagLab interface (Figure 5). However additional 
tools are available via keystrokes outlined within Help > Help (Figure 6). For additional 
information regarding TagLab tools, go to file:///C:/TagLab-main/docs/TagLab.html. For 
information regarding criteria for annotating coral patches, refer to Measuring coral vital 
rates using structure-from-motion photogrammetry at fixed sites: standard operating 
procedures and error estimates Section 1: ArcMap Segmentation and Annotation 
(https://repository.library.noaa.gov/view/noaa/32739).  

1. Create new coral annotations using either the 4-clicks segmentation tool , 

the positive/negative clicks  tool, or the freehand segmentation tool . 
Oftentimes, the 4-clicks segmentation and positive/negative clicks tools can 
reduce annotation time.  

a. To use the 4-clicks segmentation tool (Figure 9): 
i. Hold shift and use the left mouse button to place four points on the 

coral patch’s extremes (extreme top, extreme bottom, extreme left, 
extreme right) and press spacebar to create the delineation.  

ii. When the 4-clicks segmentation tool is in use, it is not possible to 
select any other coral patches.  

iii. Oftentimes, 4-clicks segmentation tool requires fine-scale editing 
and addition of partial mortality patches within the coral patch’s 
perimeter. To add these edits, continue to step 2.  
 

https://repository.library.noaa.gov/view/noaa/32739
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Figure 9. 4-clicks segmentation tool. Red crosses will appear for the first three clicks (left). The 
final fourth click triggers automatic segmentation. After completing the fourth click, TagLab may 
take a few seconds to load the new delineation (right). 

b. To use the positive/negative clicks tool (Figure 10): 
i. Zoom into the coral you wish to annotate, framing the entire coral 

patch. 
ii. Place a positive click (shift + left click) near the center of the coral 

patch. 
iii. Add additional positive and negative (shift + right click) points as 

needed and press space bar to confirm.    
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Figure 10. Positive/negative clicks tool. Positive clicks (green circles) add area to the coral patch 
and negative clicks (red circles) remove area from the coral patch. 

c. To use the freehand segmentation tool (Figure 11): 
i. Hold down the left mouse button and trace the perimeter of the 

coral patch. Release the left mouse button and press the spacebar 
to save the annotation.  

ii. If the spacebar is pressed but the delineation does not turn white, 
there may be a hole in the delineation. Close the hole and press the 
spacebar again. 

iii. Rather than creating a single continuous line, multiple lines can be 
linked together to create the perimeter around a coral patch (Figure 
11).  
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Figure 11. Freehand segmentation tool. Connections between separate segments making up a 
single patch are exaggerated and will be removed once the patch is completed. Use exaggerated 
segment ends to ensure small spaces between segments do not exist. If there are any spaces, the 
patch may not save. 

2. To edit patch borders and add in partial mortality within the patch, use the edit 

border tool , The refine and cracks  tools are also available. For more 
information on the latter two tools, go to file:///C:/TagLab-main/docs/TagLab.html.  
 

a. To make fine-scale edits along the coral patch perimeter, select the edit 
border tool and, with the existing patch delineation selected, draw (left  
click and hold) a segment that intersects the existing delineation at two 
separate points (Figure 12, top left). Press spacebar to complete the edit. 
The section of line outside the annotation will be added and the section of 
line within the annotation perimeter will be removed from the patch (Figure 
12, top right).  

b. To remove partial mortality within a coral patch, select (double click) the 
patch you wish to add the partial mortality border to and annotate the 
partial mortality by left clicking and moving the mouse (Figure 12, bottom 
left). Once complete, press the spacebar to save (Figure 12, bottom right).  
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Figure 12. Edit border tool. The gray perimeter is the existing annotation and the black segments 
are the edited regions (left). Once edits are complete, press the spacebar to save changes (right). 

3. To assign a species code to a coral patch, select the patch(es) to which you wish 
to assign a species and, in the Labels panel, double click on the species code. 
Make sure to double click the species code name rather than the colored box in 
the Labels panel.  

a. To remove a species label, select the patch(es) and double click on the 
Empty label within the Labels panel. 

4. To delete a patch, select the patch and press the delete button.  
5. To merge patches together, select both patches (select one patch, hold shift, and 

click on the other patch(es)), and press the letter m.  

6. To separate patches, use the cut segmentation tool , draw a line along the 
border between the two coral patches, and press the spacebar when complete 
(Figure 13).   
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Figure 13. When using the cut segmentation tool, ensure that the existing patch annotation is 
selected (patch will turn white when selected) and the new border line (black) cuts through at least 
two parts of the patch perimeter (left, red arrows).  Additional edits may be needed after splitting 
the patch to properly outline all live coral tissue (right, red arrow points out region where the 
perimeter for the coral on the left needs editing). 

4.4 Link Coral Patches: 
The goal of this SOP is to generate data to track patterns of colony-level change. We do 
that by first annotating contiguous live coral patches. Once all coral patches have been 
annotated at every time point, the annotator will link patches from each time point to the 
closest consecutive time point. Patch linkage will be used to analyze growth, mortality, 
fission, fusion, and recruitment. During the patch linking process, individual coral 
patches are grouped into colonies (also called genets), which are displayed within the 
TagLab interface during the patch linking process. 

1. Open a TagLab project with two or more coregistered maps with completed coral 
annotations in TagLab. 

2. With the earliest time point in view, select the Split Screen tool . The closest 
subsequent time point will automatically appear on the right side of the working 
view.  

a. Ex: If the 2014 time point is in view when the Split Screen tool is selected, 
the 2014 time point will appear on the left side of the working view and the 
2015 time point will appear on the right side of the working view.  

b. Use the drop down lists at the top of the TagLab interface to change which 
orthomosaics are in view after Split Screen has been selected (Figure 14). 

3. Select Comparison > Compute Automatic Matches or click on  to 
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automatically link patches between the two time points in view.  
a. If a notification pops up asking to replace all existing matches, only select 

Yes if manual alterations have not been made or you wish to overwrite 
manual alterations between the two selected time points.  
 

 

Figure 14. TagLab interface when Compute Automatic (or Manual) Matches is selected. Both time 
points will be in view (earlier time point on the left) and the Comparison table will appear on the 
right side of the interface.  To search for patch links, select a patch within either time point or 
double click on a row in the Comparison table. In this example, selecting a single patch in one 
time point (the later time point) will select multiple patches in the other time point if a fission or 
fusion event has taken place (in this example, a fusion event has occurred for the purple colony). 

4. Links between patches can be manually edited by selecting the Add Manual 

Matches Tool .  
a. To group patches from the same time point into the same colony 

(“genets”), select one of the patches, hold shift, and left click on the 
remaining patches. Press the spacebar to link the patches in the 
comparison table (each patch should be highlighted in the table after 
pressing the spacebar (Figure 14)).  

b. To group patches between time points, select a coral patch from either 
time point, hold shift, and left click on the same patch(es) in the other time 
point; press the spacebar to save. 

c. To remove an existing link between patches, select one of the patches 
and press delete. This action will remove ALL matches among patches in 
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the genet rather than a single patch.  

5. Export Data from TagLab 
Coral annotations and linking completed in TagLab will be imported as shapefiles into 
ArcGIS to merge with the geodatabase. Maintaining a geodatabase provides an easy 
format for editing, adding metadata, and organization. Other TagLab export options 
include exporting CSV files containing all data located within the data tables,  
comparison tables (exported separately), and images of annotations (exported as 
GeoTIFFs or PNGs). 

5.1 Export Shapefiles: 
1. Once all annotation and patch linking is complete. Save the TagLab project and 

select the first time point available. 
2. To export the shapefile associated with the time point currently selected, go to 

File > Export > Export as Shapefile. 
a. Save to the site ARC folder as TYear_Site-Name_Initials 

3. Repeat until all completed time points have been exported from TagLab. 

5.2 Import and Format Shapefiles in ArcGIS: 
1. Open the existing ArcGIS site project and in the Catalog pane, navigate to the 

site’s Arc folder.  
2. Add the TagLab shapefiles to the Contents pane and open the attribute tables.  

a. All columns within the attribute that are from TagLab will end in “_TL.”  
3. The shapefiles exported from TagLab will contain all the quadrats as well as the 

annotations. To remove the quadrats from the shapefiles, select all rows created 
for the quadrats and delete them. 

4. To add additional information to the attribute tables (i.e., metadata such as site 
name, annotator initials, and other repeating values), refer to Measuring coral 
vital rates using structure-from-motion photogrammetry at fixed sites: standard 
operating procedures and error estimates Section 1: ArcMap Segmentation and 
Annotation (https://repository.library.noaa.gov/view/noaa/32739) for information 
on populating attribute tables in ArcGIS.  

5. Once all edits to the attribute tables are complete, save each attribute table and 
copy it into the geodatabase.  

a. In the catalog pane, right click on the shapefile and select Copy.  
b. Right click on the geodatabase and select Paste. 

https://repository.library.noaa.gov/view/noaa/32739


23 

 

6. Time Savings Comparison of TagLab-assisted Annotation and 
Manual Annotation in ArcGIS 

In this section we provide time savings estimates of using TagLab versus ArcGIS for 
annotating and temporally linking coral patches. Manually, this is the most time-
intensive component of extracting metrics for coral vital rates. For reference, in a 
previous study conducted by NOAA ESD, across 7 sites ranging from 2-6 time points, it 
took an average of 54.7 ± 7.5 hours per two-time point site (an average of 20 quadrat 
subsamples per site) to annotate and temporally link corals in ArcGIS.  

In this study, we chose a random sample of quadrats from sites used by Rodriguez et 
al. (2022) to compare the time required for manual coral patch annotation and linking to 
ArcGIS versus semi-automated annotation in TagLab. Quadrats were 0.5 m2 and 
contained approximately 10–50 coral patches per quadrat in each time point. 
Annotators kept track of time required for annotating each quadrat and linking time 
points separately for both ArcGIS and TagLab. For this comparison, we did not consider 
project setup time (i.e., importing shapefiles and orthomosaics, creating attribute 
tables), nor was our goal to quantitatively compare coral area or perimeter calculations 
between ArcGIS and TagLab (though qualitatively, they are very similar). 

6.1 Results: 
In total, 5 quadrats were surveyed across three sites, resulting in 256 total patches 
annotated and linked. These sites included Rodriguez et al. (2022) study sites from 
Hawaii, Maui, and Pearl & Hermes. Four of the quadrats were annotated and linked 
across two time points and 1 quadrat was annotated across three time points. Time 
spent annotating a single quadrat was very similar between TagLab and ArcGIS (Table 
1). However, linking corals in TagLab resulted in a 41% reduction in hands-on time 
compared to linking in ArcGIS (Table 1). Overall, TagLab resulted in a 14% reduction in 
personnel time. As these estimates stem from a relatively small number of quadrats and 
inter-quadrat variability is high, we treat these values as pilot data.  
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Table 1. Average time (minutes) required to annotate and link coral patches in TagLab and ArcGIS, 
with extrapolation to total quadrat time in both 2 and 3 time point cases. Then there is further 
extrapolation to Total Annual Annotation/Linking Time assuming 10 sites, each containing 15 
quadrats, evenly split among 2 and 3 time point sites. 

Quadrat-Scale 
Annotation 
and Linking 
(0.5 m2) 

TagLab Time 
(minutes ± SE) 

ArcGIS Time 
(minutes  ± SE) 

Mean TagLab 
Improvement 
(minutes ± SE) 

Mean TagLab 
Percent 
Improvement 

Annotation 
Time: Single 

Quadrat 

36.8 ± 6.7  36.8 ± 4.5  0 ± 8.1 0% ± 21.9% 

Linking Time: 
Two Time 

Points 

16.7 ± 5.3  28.3 ± 8.0 11.6 ± 9.6 41.0% ± 33.9% 

Total Quadrat 
Time: 

Two Time Point 
Extrapolation 

90.3  103.6 13.3 12.8%  

Total Quadrat 
Time: 

 Three Time 
Point 

Extrapolation 

143.8 170.5 26.7 15.7% 

Total Annual 
Time: 

 10 Sites: 
 8@2TP / 
2@3TP, 

15 quads each 
(person-hours) 

252.5 person-
hr 

292.5 person-
hr 

40 
person-hours 

13.7% 

6.2 Conclusion and Recommendations: 
Overall, our results suggest that extracting vital rates data from large area imagery does 
not vary greatly between TagLab and ArcGIS. However, incorporating TagLab into our 
vital rates workflow could improve labor efficiency by 14%. Given that the workflow for 
extracting vital rates is labor intensive, any and all improvements in efficiency are 
meaningful.  
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TagLab is an ongoing project of the Visual Computing Lab and remains a novel 
software with consistent updates to their semi and fully automatic segmentation and 
linking tools. Currently, NOAA ESD has only utilized several of TagLab’s semi-
automatic tools that provide varying degrees of accuracy and require manual edits to 
rectify. As TagLab continues to improve the accuracy of their semi-automatic tools and 
as NOAA ESD incorporates TagLab’s fully automated annotation tools, time savings are 
expected to increase significantly. By engaging with TagLab and generating region and 
taxa-specific training data, improvements in semi and fully automated tools are 
expected to increase as seen with other organizations currently using TagLab (Pavoni 
et al. 2021). 

TagLab provides a more user-friendly interface for both annotating and linking corals 
than ArcGIS. TagLab was created specifically to meet the needs of annotating corals 
and provides tools that quickly and easily outline the complex morphologies that corals 
form. Conversely, ArcGIS is predominately used for mapping and spatial analysis. While 
its metadata and shapefile compilation abilities are helpful, the interface is not attuned 
to the needs of our annotators, and it does not provide tools specifically designed to 
outline live coral patches.  

TagLab and ArcGIS both have advantages and disadvantages when it comes to 
extracting vital rates data. Currently, there is a place for both ArcGIS and TagLab to 
exist within the vital rates workflow. Given that unique coral patch IDs are preserved 
between TagLab and ArcGIS, we can use them interchangeably as needed in the 
future.  
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